CVE-2026-73263
Açıklama (NVD)
Prowler is a cloud security platform. Prior to 5.36.0, the Kubernetes provider connection test accepted kubeconfig_content containing a legacy gcp auth-provider with config.cmd-path and config.cmd-args because kubeconfig_contains_exec_auth in api/src/backend/api/v1/serializers.py checked only exec blocks, and POST /api/v1/providers/{id}/connection loaded it through config.load_kube_config_from_dict in prowler/providers/kubernetes/kubernetes_provider.py, causing kubernetes-python CommandTokenSource.token to run the attacker-supplied command through subprocess.Popen on the shared worker. This issue is fixed in version 5.36.0.
Yayın: 12.08.2026 · Son değişiklik: 24.10.2026 · Zayıflık: CWE-78
CVSS 3.1 metrikleri
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
| Saldırı vektörü | Ağ (uzaktan) |
| Karmaşıklık | Düşük |
| Gereken yetki | Düşük |
| Kullanıcı etkileşimi | Gerekmez |
| Kapsam | Değişir |
| Gizlilik | Yüksek |
| Bütünlük | Yüksek |
| Erişilebilirlik | Yüksek |
Hesaplanan temel puan: 9.9. CVSS hesaplayıcıda incele